Several Reported Wi-Fi Anomalies

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 16:30 EDT

Investigating

We've received and confirmed several reports concerning difficulties accessing the internet while connected to the Redeemer network. We are working on a solution and hope to have everything back up as soon as possible.
Posted Sep 11, 2026 - 14:21 EDT
This incident affected: Networking (WiFi (Wireless Internet)).