Printing Outage

Incident Report for Redeemer University Status

Update

We are continuing to work on a fix for this issue.
Posted Sep 11, 2026 - 16:30 EDT

Update

Update | Printing Outage | print.redeemer.ca is Fixed!

Webprint (print.redeemer.ca) is fully operational again!

We are still working on a permanent solution for the driver install request on Redeemer devices. Please continue to either use a USB or print.redeemer.ca to complete any printing jobs (avoid using 'direct print'). If you have any questions, please stop by the IT Help Desk.
Posted Sep 04, 2026 - 11:51 EDT

Identified

We are still working on a permanent solution for the current printing outage. At this time, the most reliable method of printing is USB (specifically PDFs on a USB stick).

To print using a USB stick, please sign into a Canon printer on campus and insert your USB. Then, navigate to the Home menu (click "Access Device") and select "Access Stored Files > Memory Media". Don't forget to eject your USB when you are finished.

Note: not all USB sticks work on our printers. If you are unable to print using your USB and you need your documents printed by end of day Wednesday, please stop by the IT Help Desk and we can assist you.

Thank you for your patience as we work to resolve this issue!
Posted Sep 01, 2026 - 17:13 EDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 09:38 EDT

Update

We are continuing to investigate this issue.
Posted Aug 31, 2026 - 11:18 EDT

Investigating

BOTH Direct Printing and PRINT.redeemer.ca ("webprint") services are not functional - out of service.
We are currently investigating these issues.
(Problem was initially noticed and reported the morning of: Monday, 31 August 2026); it MAY have been out of service for as long as - since - Friday the 28th of August 2026.
Posted Aug 31, 2026 - 10:07 EDT
This incident affects: Printing Services.