Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2026 - 17:00 EDT
Scheduled
There are several system updates we plan to complete between 5pm-6pm Thursday, August 20th. During this process, several Redeemer applications may be unreachable and the dorm wifi may be down for up to 30 minutes.
Please avoid completing any work on Redeemer sites during that time and ensure you work is saved before 5pm. Thank you!
Posted Aug 19, 2026 - 15:02 EDT
This scheduled maintenance affected: Networking (WiFi (Wireless Internet)), OneCard Services (Point of Sales, Transactions, Cash Register), and SSO/Password Access, "Other" or "Miscellaneous".