Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 10:00 EST
Scheduled
We will be conducting some brief maintenance on Discovery from 10am-11am on Saturday, Jan 31st. During that time, Discovery will be unavailable (you will not be able to log in and you will be removed if you are already logged in).
Posted Jan 27, 2026 - 11:29 EST
This scheduled maintenance affected: Discovery (aka Moodle).