Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2026 - 09:00 EDT
Scheduled
We will be applying a security patch to our printing server tomorrow morning at 9am. The update should be completed by 10am. Please avoid using any method of printing during the maintenance. Thank you!
Posted Sep 09, 2026 - 12:14 EDT
This scheduled maintenance affected: Printing Services.