Self Service Outage

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 10:14 EST

Investigating

Self Service appears to be down. We are looking into the issue and hope to have it resolved soon.

Error: “The SAML response provided by the identity provider could not be validated.”
Posted Nov 18, 2025 - 20:00 EST
This incident affected: Self Service.