Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 00:01 EST
Scheduled
If you have a Redeemer-issued Windows computer, please leave it on and under power (leave the charging cord in) for a few hours over the weekend to ensure your device receives all the necessary updates without interrupting your work day. Thank you!
Posted Jan 09, 2026 - 12:07 EST
This scheduled maintenance affects: "Other" or "Miscellaneous".