Respondus Login Issue

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 15:01 EDT

Monitoring

There was an issue with Respondus loading Discovery's login/exam start page during the morning gym exam slot. We have determined what caused that error and are confident that it won't happen again.
Posted Apr 14, 2026 - 09:00 EDT
This incident affected: Discovery (aka Moodle).