Network Issues

Incident Report for Redeemer University Status

Resolved

The network issues are resolved! If you continue experiencing issues, please try restarting your device and/or contacting the IT Help Desk. Thank you for your patience!
Posted Nov 28, 2025 - 10:30 EST

Investigating

We are currently experiencing some network issues that are causing some devices to drop connection randomly for a handful of seconds. This is increasing the response times for OneCard taps (doors will take longer to open, payments will take longer to process).

We are looking into the cause and hope to have it resolved soon!
Posted Nov 28, 2025 - 10:00 EST
This incident affected: Networking (Ethernet/Wired Internet, WiFi (Wireless Internet)).