POS testing was successfully. The system is fully operational!
Posted Nov 27, 2025 - 14:10 EST
Monitoring
Printing is fully functional again! We are currently testing our POS systems to ensure they are fully operational as well!
Thank you for your patience!
Posted Nov 27, 2025 - 14:01 EST
Investigating
Most of our POS systems are currently down. We are looking into the issue and hope to resolve it soon.
As a result, our printing systems currently are not able to charge to personal funds. If you are a student and need a documented printing this morning, please visit the Help Desk in person and we can print it for you.
Posted Nov 27, 2025 - 09:34 EST
This incident affected: OneCard Services (Point of Sales, Transactions, Cash Register) and Printing Services.