Unexpected Outage with our SSO Page & Redeemer WiFi

Incident Report for Redeemer University Status

Resolved

Our SSO page is successfully loading on Redeemer Wi-Fi again! Thank you for your patience as we fixed this issue.
Posted Feb 02, 2026 - 11:33 EST

Update

A work around has been discovered: If you hotspot to sign in, you should be able to reconnect to Redeemer Wi-Fi and use those applications.

We are hoping to resolve the underlying cause soon!
Posted Feb 02, 2026 - 11:21 EST

Investigating

Our Single Sign-On (SSO) page appears to not be working on Redeemer WiFi at the moment. This means that you will not be able to log into some applications (Self Service, RU App, AIM, etc.) while connected to Redeemer WiFi until this issue is resolved.
Posted Feb 02, 2026 - 10:47 EST
This incident affected: OneCard Services (One Card (TouchNet)), Networking (WiFi (Wireless Internet)), and Redeemer App, Self Service, SSO/Password Access.