Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 05, 2026 - 22:00 EST
Scheduled
We will be performing some maintenance on Redeemer's phone system tonight starting around 10PM. Phones will not work during this time. It should be completed by 11PM.
Posted Feb 05, 2026 - 16:42 EST
This scheduled maintenance affected: Telephone System.