Partial Printing Outage - Use ecoprint.redeemer.ca instead of print.redeemer.ca

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 12:45 EST

Investigating

The URL we will be transition our printing services to (print.redeemer.ca) is currently not working on Redeemer Wi-Fi. If you are unable to reach the printing site, please use ecoprint.redeemer.ca instead.
Posted Feb 24, 2026 - 14:30 EST
This incident affected: Printing Services.