Unexpected Self Service and Colleague Outage - Starting 4:30pm Sept 3, 2025

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 14:51 EDT

Investigating

We've received several reports that many features on Self Service and Colleague are not working. We are looking into the issue and hope to resolve it as soon as possible. In the mean time, if you need information about a specific class (location and/or time) from your schedule, please email helpdesk@redeemer.ca with your course code. Thank you for your patience.
Posted Sep 03, 2025 - 16:30 EDT
This incident affected: Ellucian Colleague and Self Service.