Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2026 - 13:00 EDT
Scheduled
We will be making improvements to the networking in the science area (faculty pods, lab and classroom area, hallway in that area) to help improve speed and reliability tomorrow starting at 1pm. During this maintenance, all internet access will go down intermittently in that area. To limit interruptions, please avoid doing any work that requires internet access in that area.
Posted Jun 10, 2026 - 12:25 EDT
This scheduled maintenance affected: Networking (Ethernet/Wired Internet, WiFi (Wireless Internet)).