Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 22, 2025 - 10:00 EST
Scheduled
We will be updating reset.redeemer.ca.
During this time, you will not be able to access the site to change your passwords. If your password is due to expire soon, please change it before the 22nd to ensure you don't lose access to your account during this maintenance.
Posted Dec 18, 2025 - 11:19 EST
This scheduled maintenance affected: SSO/Password Access.