The phone system is fully operational again! If you notice any issues, please contact the IT department. Thank you for your patience!
Posted Sep 08, 2025 - 15:00 EDT
Update
The replacement configuration is more challenging than initially expected. We are working hard to fix it as soon as possible but, at this time, the phone system is still down externally. We will continue to send updates as progress is made.
Thank you for your patience!
Posted Sep 08, 2025 - 14:23 EDT
Update
We have identified the problem and a replacement part is on its way. We hope to have the system restored by noon.
Thank you for your patience!
Posted Sep 08, 2025 - 10:05 EDT
Identified
We are currently investigating the issue and hope to resolve it soon. It appears that all external-related calls are not working (i.e., someone trying to call Redeemer will not reach us and you will not be able to use a Redeemer phone to call externally). Calling someone's extension still works if you are using a Redeemer phone.