Printing Outage

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 09:29 EDT

Investigating

Our printing service is currently down across campus. We are working to resolve the issue as soon as possible! In the meantime, please refrain from printing until the outage has been resolved. Thank you!
Posted May 31, 2026 - 02:30 EDT
This incident affected: Printing Services.