Charis WiFi ongoing issues ... there may still be issues with online games and some chat services

Incident Report for Redeemer University Status

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 10:00 EDT

Update

We are continuing to investigate this issue.
Posted Sep 05, 2025 - 16:59 EDT

Investigating

Charis WiFi ongoing issues ... there may still be issues with online games and some chat services

We apologize for any inconvenience.

The IT Team
Posted Sep 05, 2025 - 12:19 EDT
This incident affected: Networking (WiFi (Wireless Internet)).