VPN is operational again. We are still working to fix the other outages.
Posted Mar 25, 2025 - 12:04 EDT
Investigating
There are network issues affecting several systems: - Phones are unable to connect to the network in the main offices - Printers are unable to connect to the network in the main offices - Several hard-wired computers are unable to connect to the network in the main offices - VPN appears to be down
Posted Mar 25, 2025 - 09:30 EDT
This incident affected: Networking (Ethernet/Wired Internet, VPN (Virtual Private Network)).